Use the Mac terminal to create a Live/Boot USB.
Step 1 – Have your “disc-image.iso’s” ready in an easy to navigate to folder and open the Terminal. Step 2 – Convert the .iso file to .img using the convert option of hdiutil by first navigating to the folder containing the ISO using the CD command and then use the following……
hdiutil convert -format UDRW -o LinuxMint-15-x86.img LinuxMint-15-x86.iso (as examples!)
Note: OS X tends to put the .dmg ending on the output file automatically. Step 3 – Insert your USB flashdrive and determine the it’s device node assignment via the discutil command with the CLI; via the Disc Utility within OSX; or via the System Information, within /Hardware/Storage. The CLI command looks like this:
diskutil list
Step 4 – Unmount the drive with the following CLI command: Make sure you have the correct device address!! eg: /dev/disk1 or /dev/disk1s1
diskutil unmountdisk /dev/disk1s1
Step 5 – Do some housekeeping by executing the following CLI:
sudo dd if=./linuxmint-15-x86.img.dmg of=/dev/rdisk1 bs=1m (again, these are my examples!)
Step 6 – Eject the flash drive and you are done!
diskutil eject /dev/disk1 (example!)
Use the Mac terminal to shutdown (good for a rouge process holding up a regular shutdown).
Step 1 – Open the Terminal and type the following into the command prompt: for reboot:
sudo shutdown -r now
or
sudo reboot
for halt:
sudo shutdown -h now
or
sudo poweroff
or
sudo halt
Step 2 – If you want to delay the shutdown for a period of time, say three hours, then just type:
sudo shutdown -h +180
Step 3 – Furthermore, if you want to find out more information you can read the OSX manual pages from the command line by:
man
or (for the manual pages on the shutdown command)…
man shutdown
Create a bootable Mavericks USB Install Drive.
(Reproduced with many thanks from Macworld here) Step 1 – From within Lion/Mountain Lion/Mavericks, open the App Store and download the latest version of the Mavericks installer. Once installed, the Mavericks installer file (all 5.29GB of it – as at 30 Oct 13) will reside within the Applications folder.

Step2 – Insert a (or is it “an”) USB Drive of 8gig or larger capacity into your Mac, and format the device with OSX’s Disk Utility using the following settings:
- Name: Untitled
- Format: Mac OS Extended (Journaled)
- Partition Map: GUID Partition Table
Step 3 – Open the Terminal and use the following command to write the bootable Mavericks installer to the USB using OSX 10.9’s createinstallmedia tool:
sudo /Applications/Install\ OS\ X\ Mavericks.app/Contents/Resources/createinstallmedia --volume /Volumes/Untitled --applicationpath /Applications/Install\ OS\ X\ Mavericks.app --nointeraction
Step 4 – Enter your SU password when prompted, and wait for the createinstallmedia tool to complete the write (about 25mins for my 8gig USB drive).
Step 5 – To boot from your newly created Mavericks USB Drive, either open the Startup Disk application from within System Preferences and highlight your new bootable drive OR hold down Option during the boot sequence and select the Install OS X Mavericks 10.9 USB.
Maximise OSX 10.9 Mavericks Windows to fill the whole desktop (Like Windows/Ubuntu/Linux Mint).
Download Right Zoom from http://www.blazingtools.com/right_zoom_mac.html Open the Zip and run the installation file. If OSX warns you of the dangers of opening a file downloaded from the internet from an unidentified developer……

….click “OK” to acknowledge and close the pop-up and reopen the file by holding down “Command” and Right-Click to select the “Open” menu item, and you will see a similar looking pop-up, but with the additional option of being able to open (and therefore install) the software.

Once the software is installed, open the application and select your preferred options regarding the behaviour of Right Zoom’s window maximising Mac OS tool. Just remember to “Apply” each change before closing the configuration window (example below).

Check MD5 and SHA-1 CheckSums/Hashes using OSX Terminal.
Download your file and remain on the webpage, or carefully copy the MD5 or SHA-1 hash/checksum to another place (better to copy & paste than risk errors).
Once you have downloaded the file, open the terminal and navigate to the directory which contains the file and use the following commands as appropriate:
md5 2014-01-07-wheezy-raspbian.zip
or
shasum 2014-01-07-wheezy-raspbian.zip
or
shasum /path/to/file/2014-01-07-wheezy-raspbian.zip

.

.
Edit config and other text files using the OSX Terminal.
Edit config and text files from within the Terminal of OSX (much like we do with nano/gedit etc in Linux).
sudo open -t /etc/hosts
Make hidden files and folders appear – like magic 😉
Option 1
Open your Mac Terminal and enter the following command:
defaults write com.apple.finder AppleShowAllFiles YES
killall Finder
Hidden files and folder will now appear as transparent icons as soon as you reopen a Finder window.


Option 2
Open your Mac Terminal and enter the following command:
defaults write com.apple.finder AppleShowAllFiles YES
Then, while holding down “Alt”, right-click on Finder and select “Relaunch”.
Next time you open Finder, all hidden files and folders should now be visible (but pale) by default.
Edit a 3rd party, System Config File with the command line text editor.
Open the Mac Terminal (Applications/Utilities/Terminal.app) navigate straight to the location of the file you wish to edit (technically not necessary, but I find it useful to be in the the same working directory as the file I wish to access). There are two methods to get to the relevant directory. First involves just manually by navigating there with the cd command (call directory). The easier way is to locate the file within Finder (you may need to make hidden files & folders visible by default), and then drag the file onto the Terminal window. This provides you with a direct pathway address to the file, which you can prefix with cd to get straight to the relevant directory. Spotlight is good for this, as you don’t need to know the specific location of the file to being with. Just use Spotlight to locate the file, then, once found, drag it on the Terminal window.
Now, if the file is a Config file you should be able to open and edit it with the usual:
sudo open -t /etc/hosts
As an example. However, if your file is from a 3rd Party Developer not certified or recognised by Apple, then you may be greeted by a pop-up window such as:
—————-Currently under construction———————
—————-More to follow———————-
Enable the OS X ‘Verbose’ boot mode.
To enable the verbose boot mode upon startup, you can either:
- Hold down Command + V (⌘ + V) as the system first boots to enable a single verbose boot; or
- For a more permanent solution, which remains persistent across boot-cycles/system restarts etc, use the following in the Terminal/BASH:
sudo nvram boot-args = "-v"
The above command enables the verbose boot……
sudo nvram boot-args =
The above command disables the verbose boot…..
NB: I haven’t tested it myself, but I’ve read that FileVault turned on, as well as Firmware password being set interfere with Verbose boot mode being activated using the above commands.
Not sure if there is a fix, if this is a problem. As hinted, I don’t use FileVault or Firmware Passwords.
Use Preview to merge several *.pdf files into one.
Had a problem with Word for Mac 2011 (fully updated) splitting my document into two separate *.pdf files when I tried to save it as a PDF.
This work is licensed under a
Creative Commons Attribution-ShareAlike 3.0 Unported License.